Inga kända driftsstörningar

June 1, 2009

XBMC, Xbox Media Center

January 20, 2009

Is simply the best mediaplayer that has ever existed period. It is fast, easy to use and features several interesting features such as the ability to play .rar files containg .iso files or other kinds of media.

Originally developed for the Xbox it has now been moved to Linux, Windows, Apple-TV and (most interesting) Live-CD / USB-stick which should open the opportunity for hardware manufacturers to start building cool media-center-machines.

There is no repository available (yet) for Intrepid, but in the forums someone claimed that the hardy repositories works fine. So go to:
System / Administration / Software sources and hit the “Third-party software” tab. Add these two, one-by-one:
deb hardy main
deb-src hardy main
Close and reload and goto Add/Remove applications where

SBackup doesn’t do it.

January 14, 2009

I got around to trying SBackup (again!) with hopes of finally solving that backup issue that has be botherning me for a while now. I decided to stick a usb-drive in the dock at work and then try to have the backups directed there.

Didn’t work.

What did work was the first few rounds of backups. It ran at the designated tiime and it placed tha backups in the right spot (which was /media/disk-1). The problem was that when I was out of the office the backup still ran, quietly. Still backing up to /media/disk-1 which in those cases didn’t have anything mounted. Disk became full, and I had loads of problems with it, so I disabled it again. When I have time I will try to find a solution to this, but even if there is one, this feels like something that isn’t easy enough for the average Joe and such an important function should be.

Getting rid of PulseAudio

November 25, 2008

Found an excellent guide (in Swedish) to remove PulseAudio. Basically do this:

Check that your system uses Pulseaudio (it says clearly by Card and Chip) in the top left corner.

sudo rm /etc/X11/Xsession.d/70pulseaudio
killall pulseaudio
sudo apt-get remove pulseaudio
sudo apt-get install esound

Then run:
And check that it is not using PulseAudio any longer.

I will report after thorough testing if it works fine.

XBMC yes, as long as you get rid of PulseAudio

November 23, 2008

As I wrote in my earlier post about PulseAudio it doesn’t work to well with XBMC Media Center.

I have now been using XBMC quite a lot for a full week and have no problems what so ever, as long as PulseAudio is closed first.

sudo killall pulseaudio

As soon as I have a little more time I will investigate how a uninstall of PulseAudio could affect the system…

XBMC and Pulseaudio

November 19, 2008

Xbox Media Center seems to have a share of problems on my system. The most recent events has been that the audio seems to crash, either going silent or getting stuck in a endless loop that’s quite annoying. This seems to happen quite often if I jump in movies.

The first solution, rebooting the system, wasn’t exactly neat. The second is sort-of work-in-progress. But it seems to work which is nice:

In System – Preferences – Sound I’ve changed all settings to use ALSA screenshot-sound-preferences

Then either before I start XBMC or when the problem occurs I run:

sudo killall pulseaudio
ps aux | grep pulse

If there still is pulseaudio processes left I kill them with

sudo kill -9 whateverprocess

I think this happens mostly when I has been running XBMC and the audio is hung. Of course the ideal thing here would be to disable pulseaudio completely, or to pray for team-xbmc to fix this. I have not decided what to do yet, I have to do some reading on this PulseAudio, it might be there for some other reason than to break XBMC.

Network Manager only allows one vpn connection

November 10, 2008

Darn, today I got around to installning my second vpn which gave me more trouble than I asked for. I have been running my primary connection to my office for a while and it has been working flawlessly, it’s really, really nice to be able to manage stuff like this in the network manager.

The second vpn connection, to a datacenter at work is not working as well though. First I have some kind of routing problem – when this is connected I can’t access anything outside of the vpn-route

The explanation is in routing. But I didn’t succeed in fixing it in the network manager settings. Will try again when I have more time.

default * U 0 0 0 tap0

The other thing that has pussled me is that I cannot activate both my vpn’s at the same time. First I thought it was a configuration misstake (since I have been using these two OpenVPN connections simultaneously on 8.04) but the I found this on Ubuntu Brainstorm. It seems to be a limit set in Network Manager. Bummer.

Should be easy to fix though, since it was working outside NM, hopefully someone with skillz will do that.